Mac will not respond to boot keyboard commands

I was asked to wipe and reinstall a MacBook Air (mid-2013) for work, which would normally be a simple task of booting into recovery mode, wiping the disk in the Disk Utility and using the “Reinstall” option to put back a blank copy of the OS. However, this particular MacBook Air seems to have an issue with the keyboard commands on boot.

No matter which of the commands I tried:

  • Cmd+R – Boot into Recovery Mode
  • Cmd+Option+R – Boot into Internet Recovery Mode
  • Cmd+S – Boot into Safe mode
  • Cmd+Option+P+R – Reset the NVRAM/PRAM

None of these had any effect and it would simply boot to the login screen. I assumed there must be something wrong with the built-in keyboard, so I logged into an account on the machine to test it, but everything on the keyboard appeared to work and keyboard shortcuts like Cmd+R (see above) worked fine, for example, to refresh the page in the browser.

I did some searching around, read various posts on various sites, blogs and forums, but none seemed to show the same issue. I grabbed a USB stick and created a macOS install media on it and gave that a try instead, however, to boot to a USB stick you have to hold down the Option key on boot, which, of course, didn’t work either.

I got an external Mac bluetooth keyboard and connected that to the laptop whilst logged in and then rebooted and tried holding the keys above on the external keyboard during boot as well, but that didn’t work either. I then came across a post on the Apple community forum where someone said that sometimes the bluetooth keyboards are only recognised “after boot” and if you need to perform something at boot time with an external keyboard you need to plug it into the USB socket using a USB to lightning cable. So I connected it up and bang, it worked, holding Cmd+R on the external keyboard at boot put me into recovery mode.

I still have no idea why this particular Macbook’s built-in keyboard doesn’t work at power on, as it should, but the trick with the USB cable and external keyboard saved the day. Even after wiping and reinstalling the MacBook and resetting the NVRAM/PRAM, the built-in keyboard still doesn’t respond to the boot commands.

Leave a Reply

Your email address will not be published. Required fields are marked *